BnetD for win 下载地址1

[2004-09-08]本次更新添加了许多奶牛游侠论坛的新内容和失落之城的内容,感谢阿吉。注意：没有注明110的项目基本上是109 110通用。架设软件bentd 只支持暗黑，pvpgn支持暗黑 war3 和星际 。最后再次说明 这个教程只能让你架设出能用的封闭战网，如果你想挖掘能多的功能欢迎来我的论坛讨论。

[2003-06-08]本教程大量采用奶牛游侠论坛的『暗黑GM讨论区』内容，最后由tuzi整理。 感谢论坛的另外一位坛主oo和斑猪zhycn,还有 ahfei和SJZGM 和其他在讨论区里的朋友们。如果您有什么建议或者其他问题，请访问奶牛游侠论坛。

========暗黑架站攻略Ver0.3=========

所有能用到的软件请到以下2个地址下载

兔子的论坛：http://opac.nenu.edu.cn/cgi-bin/forums.cgi?forum=16

阿吉的论坛：http://www.lostcity.cn/bbs/index.php?showtopic=253

祝好！
你的朋友：tuzi tuzi@fescomail.net


这个只支持暗黑109

这个主要供各个GM测试服务时使用，同时也让新手感到暗黑server架设其实很简单！

 ＝＝首先确定你要做服务器的机器上安装了diabloII游戏＝＝

1:将bnetd-win32.rar 解压至任意位置，运行其中的diablostar.exe，选择启动服务
2:将D2GS1.9.1.5_for_bnetd.rar 解压，其内容复制到diabloii所在的目录，执行install.bat
3:在win2k的控制面板－>服务中启动Diablo II Close Game Server服务〔就一个服务〕
4:导入注册表test.reg
5:向进其他战网一样进自己的战网吧！^^

祝好！
你的朋友：tuzi


步骤：其实和3分钟搞定的那个只是略有不同！

注：所说的cs服务器就是安装了bnetd的那个机器
所说的gs服务器就是安装了暗黑和d2gs的那个机器，如果bnetd和暗黑在一个机器上，ip相同。

1:将bnetd-win32.rar 解压至任意位置，〔1.09〕##将pvpng-1.6.5ap3-win32-bin.rar解压至任意位置〔1.10 同时支持war3等〕
2：修改etc目录下的d2cs.conf文件
realmaddr = 127.0.0.1:6113 将127.0.0.1修改为你所用cs服务器的ip
gameservlist = 127.0.0.1 将127.0.0.1修改为你所用gs服务器的ip
bnetdaddr = 127.0.0.1:6112 将127.0.0.1修改为你所用cs服务器的ip
3:修改etc目录下的d2dbs.conf文件
gameservlist = 127.0.0.1 将127.0.0.1修改为你所用gs服务器的ip
4:修改etc目录下的realm.list文件
"D2CS" "Diablo2 Realm Server" 127.0.0.1:6113 no 将127.0.0.1修改为你cs服务器的ip
5:运行其中的diablostar.exe，选择启动服务

6:将D2GS1.9.1.5_for_bnetd.rar 解压〔1.09〕，##将d2gs-110-bin-beta6.rar 解压〔1.10〕其内容复制到diabloii所在的目录
修改d2gs.reg 文件将其中的ip 127.0.0.1修改为你cs服务器的ip
7:执行install.bat
8:在win2k的控制面板－>服务中启动Diablo II Close Game Server服务〔就一个服务〕
9:修改注册表test.reg 中127.0.0.1为你的cs服务器的ip，这个就是你的国度的注册表文件了
a:如果使用的pvpgn的话，在控制面板中还有pvpgn ，d2cs 和d2dbs也要启动。
b:向进其他战网一样进自己的战网吧！^^

看好了以上步骤一个也不要拉下噢！


1:给你的国度起个名字
修改realm.list文件
"Realm Name" "Diablo2 Realm Server" your.d2cs:port 将Realm Name改为你想要的国度名字
修改d2cs.conf文件
realmname = D2CS 将D2CS改为你国度的名字
2:游戏大厅上方的广告
1).修改ad.list文件(类似以下修改)
# --file name-- when- time ---------------URL--------------- --next--
"ad000001.pcx" init 30 "http://www.mynenu.net/" 0x000000
"ad000002.pcx" start 30 "mailto:admin@iool.net" 0x000001
"ad000003.pcx" start 30 "http://www.iool.net/" 0x000002
2).修改files目录下的ad000001.pcx和ad000002.pcx或者自己新建pcx图片文件。
用photoshop打开修改，记住一定要256色，否则不会显示。
3:登陆BN时的欢迎信息
修改BNMOTD.TXT文件
4:修改游戏的存活时间
见[4]管理你的战网
5:修改国度最大登陆的人数
见[4]管理你的战网
6:修改国度的欢迎信息
见[4]管理你的战网
7:用多个gs来带一个国度
修改d2cs.conf 和d2dbs.conf文件
gameservlist = ip1，ip2，ip3 //其中ip为你gs的ip地址
8:待续


[4]管理你的战网

========建立GM账号=========
记事本打开想设置为管理员的账号，/var/users目录下，在最后一行加入如下内容
"BNET\\auth\\admin"="true"

========暗黑gs端管理=======

注： “//”后的内容为注释

gs管理
telnet gsip 8888 [注意空格]
 //密码是：abcd123

//当你登陆后依次执行：
maxgame **//设置最大游戏数 我是60
maxlife **//设置游戏生存时间，单位是秒 我是7200
passwd ***//修改登陆密码 我不告诉你
gslog 0 //禁止日志生成 我是这样

到这里你应该万事ok了。
日常管理命令：

status //然后能看到下面的字样，察看gs运行状态
Maximum game number: 60//最大游戏数，此项为零即无法建立游戏，
Current game number: 60//当前游戏数
Current users in game: 122//当前玩家数
Maximum prefer users: 0
Maximum game life: 7200 seconds//游戏的生存时间
Connetion to D2CS(202.198.14*.*): connected//d2cs链接中
Connetion to D2DBS(202.198.14*.*): connected//d2dbs链接中
GS log to file: Disable//禁止gs日志
Physical memory usage: 260.898MB/284.832MB//已用gs物理内存
Virtual memory usage: 377.781MB/398.934MB//已用gs换页空间

gl //运行游戏的情况
cl **//察看gameid为**的游戏中的玩家
kick 玩家名//将玩家踢出游戏
restart **//在**时间后重新启动gs，建议不要使用
msg "sys" "#all" "你想对游戏中玩家说的话" //建议少用，让玩家心烦，但重新启动前务必使用，要不然…………
========GM的管理命令=======
注意：在游戏中和大厅中使用以下命令！！
 /kick acc
把某人从频道里踢出去,踢到the void频道里
/ban acc
把某人从频道里ban掉。
/unban
取消封禁
/announce
对整个bnet广播消息(要有announce权限),简写/ann
/addacct acc pass
新增一个acc,密码为pass
/chpass acc pass
将acc的密码改为pass,(admin only)
/restorepass acc pass
如果pass与系统记录的acc原始密码或者前一次密码符合，密码将回复为pass ,(admin
only)
/kill acc
将acc的bnet连接断开,(admin only)
/lockacct acc time
将acc锁住一定时间,time为小时数,缺少time参数则无限期lock (admin only)
/unlockacct acc
将acc解锁 (admin only)
/unloadacct acc
从bnet释放acc的内存占用 (admin only)
--------------------------------------------
祝好！
你的朋友：tuzi http://mynenu.net


[5]高阶GM读本

①d2gs服务的手动安装和卸载：
在命令行下进入diablo的安装目录[也就是d2gs的安装目录]
安装：
d2gssvc.exe -i
卸载：
d2gssvc.exe -u
d2gssvc.exe -r
上面两个命令有时用一个就行了，也有时需要从新启动计算机！！！

②服务器的硬件需求：[一家之言]
bnetd运行在win系统上的我没有测试，所以提不出来什么建议，希望有经验的GM给我提建议

[cs服务器]bnetd运行在linux下：其内存和网络速度磁盘子系统能力是主要的。在bnetd.conf文件中
preload_account = false的话，对cs服务器配置要求近一步的降低，当初Nenu有200人在线时，cs服务器的配置是PII333 128M IDE硬盘 bnetd.conf文件全默认设置[其实当时不会改]没有任何问题

[GS服务器]由于每一台GS服务器最大游戏数是150，所以Nenu现在用的GS服务器从来就没有满载过，也跟Nenu是个小网有关 ^^ ，cpu占用一直小于20% GS的配置为XEON2.0G 1GDDR内存 SCSI硬盘。为了能贴近普通用户的机器，我把Nenu的GS服务器换到我的pc机上测试了一下，XP2000+ 512M内存 80G IED硬盘，禁用了d2gs的log功能[其实还是有一些的]在该台机器上的同时在线用户120人时，cpu占用1%－5% ，内存使用172M，这样大家应该有个直观的印象了
需要注意的一点：d2gs不支持双cpu 建议：GS的机器使用1G的DDR内存！cs随便一点吧！

③bnetd运行所需要的暗黑文件列表

d2data.mpq
d2exp.mpq
d2sfx.mpq
d2speech.mpq
Patch_D2.mpq
D2GS.exe
D2GSSVC.exe
D2Client.dll
D2CMP.dll
D2Common.dll
D2Game.dll
D2gfx.dll
D2Lang.dll
D2MCPClient.dll
D2Net.dll
d2server.dll
D2sound.dll
D2Win.dll
Fog.dll
ijl11.dll
Storm.dll

④bnetd的目录结构

├─ETC 控制文件所在目录
└─VAR [默认时日志文件存储在这，建议改其位置,见[7]和[8]，d2dbs.conf同样修改]
 ├─CHANLOGS 一个不知何用的目录，一直空的
├─CHARINFO 玩家信息关联目录〔账号和人物之间的对应关系保存在这里〕
├─CHARSAVE 玩家人物存档目录
├─FILES 保存一些bn相关的文件，如banner的图片
├─LADDERS 保存天梯文件，备份别忘了这里
├─REPORTS 一个不知何用的目录，一直空的
└─USERS 玩家的账号目录，每个账号都是一个文本文件
ETC 目录下文件
├─ad.list 控制游戏大厅上方的广告
├─bnetd.conf bn 的控制文件
├─bnetd_default_user定义了默认用户的信息
├─BNMOTD 游戏大厅左侧的欢迎信息
├─channel.list 默认的游戏频道
├─d2cs.conf 国度的控制文件
├─d2dbs.conf GS服务器的控制文件
├─realm.list 国度的设置文件
└─versioncheck 版本校验文件，需要与控制文件的设置共同起作用

⑤bnetd的升级
 一般覆盖即可，但由于bnetd0.4之前和现行版本目录不一致所以需要转换工具转换，可以用bnetw2bnetd那个程序来转换。linux版的可以到奶牛游侠论坛来下载

⑥国度的备份
Bnetd本身不支持自动备份，需要手动。一定要重视备份，整个目录的备份就成，建议修改3个conf文件，将日志和国度的存档目录分开放,参考④可以确定必需备份的目录是CHARINFO 、CHSRSAVE、USERS、LADDERS、ETC、FILES，其中前4个是最重要的目录 .用linux的GM可以用linux系统指令crontab生成一个用tar每天凌晨2:00备份的策略，用win的GM可以上网搜索一个数据备份的软件拿来用就行了。

⑦BNetD、d2dbs、d2cs、d2gs各自的用途
 bnetd 主要负责bn的相关服务，如密码、天梯等信息
d2cs 是国度服务
d2dbs是负责玩家和d2gs交互的服务
d2gs就是真正和玩家相连的服务了
如果nbetd出问题了，大家就连接不到服务器了
d2cs 挂了回没有国度
d2dbs挂了无法建立游戏

⑧在d2cs.conf文件中，有一部分关于d2gs的设置，下面解释一下他们的意思：
d2gs_checksum=0
这项设置了当d2gs连接d2cs时是否检验d2gs的checksum，checksum就是在d2gs中version命令显示的那个checksum，这里设置为0，代表不检测

d2gs_version=0
这项设置了当d2gs连接d2cs时是否检验d2gs的版本，这里设置为0，代表不检测

d2gs_password=""
设置d2gs连接d2cs时的密码，相对应d2gs注册表里的是D2CSSecrect，这个密码不是telnet d2gs console的密码！

game_maxlifetime=0
游戏最长时间，这里设置为0，代表无限，也就是遵循d2gs中的设置
我的服务器这里设置为3000秒，而d2gs那里设置的是3600秒，这样做就实现了：每个游戏最长时间1小时，当一个游戏已经运行超过50分钟了，那么它就在加入列表里看不到了，免得人家进去玩不到10分钟就被踢了。

⑨linux下，有时bn服务会自己结束，例如我这里的d2cs偶尔有这样的情况，可以用下面的小脚本来解决，其他2个服务bnetd 和d2dbs如果有类似问题，将程序中的d2cs更改为相应的服务名，同时更改crontab生成策略中运行的程序的命令名
－－－－－－－－－－－－－－－－－－－－－－－－－
bn.pl 以下为其内容
#!/usr/bin/perl

system("ps -ef|grep d2cs >
check.txt");
#查看进程中是否有d2cs进程
$S_name="check.txt";
open(infile,"$S_name")||die
"Can not open source file
$S_name";
$line=<infile>;
#判断d2cs是否运行中,没运行返回值为－1
$s=index("$line","/d2cs");
if($s==-1)
{
#print "bade\n";
system("./d2cs");#再次启动d2cs服务
system("cat b.txt >>
temp.txt");#记录一次d2cs的从新启动，备查之用
}
else
{
system("cat a.txt >>
temp.txt");
}
#close(infile);

其中的a.txt和b.txt预先已经建立好了，各一句话，用于确定到底是那个循环在起作用
－－－－－－－－－－－－－－－－－－－－－－－－－－
用linux系统指令crontab生成类似以下策略－－每5分钟运行一次bn.pl
# (Cron version -- $Id: crontab.c,v 2.13 1994/01/17 03:20:37 vixie Exp $)
00,05,10,15,20,25,30,35,40,5,50,55 * * * * cd /game/sbin/;./bn.pl
我对perl没有什么了解，所以上面的脚本很烂，只是给朋友们一个思路。如果您写出了更好的for diablo的小程序，来信给我＋入这个攻略中，让更多的朋友分享您的成功的喜悦。

⑩导入人物/物品，声明：封闭的战网最忌讳这个，各位GM慎用
例子：要导入一个char：admin，要导入物品的话，把物品放在这个人物身上就好，要保证这个char在单机版是好用的！！！
步骤
在国度建立一个新人物admin
将你要导入的人物存档admin.d2s 的文件名改为admin，[该文件在暗黑的save目录下]
复制文件 admin 到/var/charsave/a/ad/目录下覆盖掉同名文件
最后进入游戏大厅，建立一个游戏或者进入其他游戏，ok!完成

⑾⑿⒀⒁⒂⒃⒄⒅⒆⒇

还有一些，但疏于整理，这次暂时不放上来了


/me
做emote指令
/whisper *acc/char msg
给acc或者char发送消息，缩写/w ,/m功能类似，但/m的接收方不可直接reply
/users
查看在线人数
/who channel
查看谁在指定的channel里面
/whois *acc/char
查看玩家在哪里
/version
显示当前运行bnet的版本号以及编译时间
/uptime
bnetd持续运行时间
/join
加入指定频道
/rejoin
重新加入当前频道
/away msg
设置状态为离开状态，当其他玩家发送消息过来时，消息内容会显示，并且发送方会看
到你的away状态,以及away的原因msg
/dnd msg
设置状态为请勿打扰，当其他玩家发送消息过来时，消息内容不会显示，并且发送方会
看到你的dnd状态,以及dnd的原因msg
/ignore
忽略某玩家
/unignore
取消忽略
/designate
指定下一任的频道管理员
/resign
辞职(不做频道管理员)
/kick acc
把某人从频道里踢出去,踢到the void频道里
/ban acc
把某人从频道里ban掉。
/unban
取消封禁
/reply msg
回复/whisper发过来的消息
/announce
对整个bnet广播消息(要有announce权限),简写/ann
/realmann
对单个realm进行广播
/addacct acc pass
新增一个acc,密码为pass
/chpass acc pass
将acc的密码改为pass,(admin only)
/restorepass acc pass
如果pass与系统记录的acc原始密码或者前一次密码符合，密码将回复为pass ,(admin
only)
/logout
登出bnet
/kill acc
将acc的bnet连接断开,(admin only)
/lockacct acc time
将acc锁住一定时间,time为小时数,缺少time参数则无限期lock (admin only)
/unlockacct acc
将acc解锁 (admin only)
/unloadacct acc
从bnet释放acc的内存占用 (admin only)

-=-=-=-=-=-=-=-=-=-=-=-=--=-=-=-=-=-

PVPgn的命令系统是灵活的可分组的权限系统，非非常好啊。

－－－－－
以下出自www.soarchin.com/bbs

Quixotic Yawl Studio的开发论坛 > 支持魔兽争霸III的服务器软件讨论 > PvPGN服务器命令大全

作者: DreamForce Apr 19 2003, 03:05 PM
请各位支持，是Ｄ—Ｄ－Ｄ－Ｄ写的，我代发。

参数解释:
< xxx >表示一个内容为xxx的参数，输入时不需要带<>，[]表示可选的参数(即也可不输入)，
/代表左右的参数选择其一
权限解释:
总管理员(admin)可以使用所有命令，频道管理员(operator/moderator)可以使用除总管理员专用命令之外的所有命令

魔兽3专用指令集:

/f
参数: m/w <信息>
作用: 给所有朋友(friend)发送悄悄话
参数: a/add <玩家>
作用: 添加指定玩家为朋友(friend)
参数: d/del/r/remove <玩家>
作用: 把指定玩家移出朋友(friend)列表

通用指令集:

/whois /whereis
参数: <玩家名>
作用: 查找一个玩家的基本信息包括他的编号和所在位置(频道或游戏中)

/message /whisper /m /w
参数: <玩家名> <信息>
作用: 给一个玩家发送悄悄话无论他在什么频道或游戏中

/ignore /squelch
参数: <玩家名>
作用: 禁止一个玩家对你发消息

/away
参数: [<信息>]
作用:
当别的玩家给你悄悄话或用whois/whereis查看你时给出一个你离开键盘的消息，如果带了<信息>参数，则同时返回这个离开信息，如果省略则取消之前的禁止

/dnd
参数: [<信息>]
作用:
禁止所有发来的消息，如果带了<信息>参数，则返回给对方这个拒绝信息，如果省略则取消之前的禁止

/who
参数: <频道>
作用: 查看指定频道的用户列表

/stats /astat
参数: [<玩家>] [<查看项>]
作用:
显示一个玩家的战绩，如果不带任何参数，则查自己的主要战绩，如果不带<查看项>参数，显示该玩家的主要战绩，带<查看项>则查专项战绩
已知的查看项参数: DRTL暗黑1战绩 STAR星际战绩 D2DV暗黑2战绩
D2XP暗黑2资料片战绩 WAR3魔兽3所有战绩 SOLO单挑战绩
TEAM随机组队战绩，其它的还待继续寻找

/time
参数: 无
作用: 显示服务器本地时间

/channel /join
参数: <频道>
作用: 进入指定频道

/rejoin
参数: 无
作用: 重新进入自己所在频道(可以将自己的名字置底)

/me
参数: <信息>
作用: 在频道中显示<你的名字><信息>，比如/me is laughing命令将显示XXX is
laughing

/designate
参数: <玩家>
作用:
频道管理员(主持人)用，指定继承者，当你用/resign命令或离开频道时继承人成为频道管理员(主持人)

/resign
参数: 无
作用: 频道管理员(主持人)用，取消头衔降为普通身份

/kick
参数: <玩家>
作用: 频道管理员(主持人)用，从本频道踢走一个玩家

/ban
参数: <玩家>
作用:
频道管理员(主持人)用，从本频道踢走一个玩家，并禁止他进入本频道直到使用本命令的玩家不再是频道管理员或离开战网

/unban
参数: <玩家>
作用: 频道管理员(主持人)用，允许被ban的玩家回到本频道

/whoami
参数: 无
作用: 显示你自己的编号和所在位置(频道名或游戏名)

/uptime
参数: 无
作用: 显示服务器迄今为止已运行的时间

/beep
参数: 无
作用: 打开一些操作声效

/nobeep
参数: 无
作用: 关闭一些操作声效

/version
参数: 无
作用: 显示服务器信息

/lusers
参数: 无
作用: 显示被ban玩家列表

/games
参数: 无
作用: 显示当前存在的游戏列表

/users
参数: 无
作用: 显示当前在线玩家，频道和游戏数量。

/channels /chs
参数: [All]
作用:
显示当前游戏的频道列表，如果带了ALL参数，则显示所有服务器支持的游戏的频道列表

/connections /con
参数: 无
作用: 总管理员可用，显示当前所有连接信息

/finger
参数: <玩家>
作用: 显示指定玩家的StarCraft/D2用户信息(性别年龄等)

/operator /op
参数: 无
作用: 显示当前频道管理员(主持人)

/admins
参数: 无
作用: 显示当前在线的总管理员列表

/reply /r
参数: <消息>
作用: 回复最后一个给你发悄悄话的人

/announce /ann
参数: <消息>
作用: 总管理员可用，发送一条通告给所有频道和游戏中的玩家

/copyright /warranty /license
参数: 无
作用: 显示服务器版权信息

/news
参数: 无
作用: 显示最新的服务器新闻(由服务器端设定的新闻)

/logout /quit /exit
参数: 无
作用: 退出战网

/kill
参数: <玩家> <时间(单位:分钟)>
作用: 总管理员可用，将一个玩家踢出战网并在指定时间内不得登录

/killsession
参数: <编号> <时间(单位:分钟)>
作用: 总管理员可用，将一个指定编号的玩家踢出战网并在指定时间内不得登录

/watch
参数: <玩家>
作用: 指定玩家登录战网时你将得到他登录的消息

/unwatch
参数: <玩家>
作用: 指定玩家登录战网时你将不再得到他登录的消息

/watchall
参数: 无
作用: 任何玩家登录战网时你将得到他登录的消息

/unwatchall
参数: 无
作用: 任何玩家登录战网时你都不会得到他登录的消息

/gameinfo
参数: <游戏名>
作用: 得到对一个正在进行的游戏的详细说明，游戏名可用/games命令查询

/ladderactivate
参数: 无
作用: 总管理员可用，将当前战网信息存入有效战网Ladder(具体作用不祥)

/ladderinfo
参数: <排名> [<查看项>]
作用: 查看Ladder指定排名的玩家，省略查看项将查看本游戏的Ladder

/timer
参数: <时间(单位:秒)> <信息>
作用: 在等待指定时间后自动发送一条消息

/netinfo
参数: [<玩家>]
作用:
显示服务器IP和端口及指定玩家的TCP/UDP的IP和端口，省略参数将查自己的信息，只有总管理员能查看他人的IP和端口

/addacct
参数: <玩家> <密码>
作用: 总管理员可用，添加一个新帐号

/chpass
参数: [<玩家>] <密码>
作用:
修改指定玩家的帐号密码，省略玩家将修改自己的密码，只有总管理员能修改他人的密码

/quota
参数: 无
作用: 显示聊天规则: 每X秒可发Y条消息，每行Z各字符，每句话不得超过W个字符……

/shutdown
参数: [<时间>]
作用:
总管理员可用，在指定时间后关闭服务器，如果<时间>被省略或为0，则取消关闭命令

/lockacct
参数: <玩家>
作用: 总管理员可用，锁住指定玩家帐号

/unlockact
参数: <玩家>
作用: 总管理员可用，解除对指定玩家帐号的锁定

/fortune
参数: 无
作用: 随机给出消息，作用不详

/mail
参数: [read]
作用: 列表你的所有邮件
参数: r/read <编号>
作用: 读指定编号的邮件
参数: s/send <玩家> <消息>
作用: 给指定玩家发送邮件
参数: del/delete <编号>/ALL
作用: 删除指定编号的邮件或删除所有邮件(参数ALL)

/flag
参数: <编号>
作用: 总管理员可用，调试(显示)指定的编号的图标

/tag
参数: <查看项>
作用: 总管理员可用，调试(显示)指定游戏的图标

/help
参数: <命令>
作用: 查看指定命令的帮助

/ipban
总管理员可用
参数: l/list
作用: 查看被ban的IP列表
参数: c/check <IP>
作用: 查看指定IP是否被ban
参数: a/add <IP> [<时间(单位:分钟)>]
作用:
添加IP到ban列表，将其ban指定的时间，如果省略时间或时间为0，则完全ban一个IP
参数: d/del <IP>/<编号>
作用: 从ban列表中删除指定IP/编号的IP使其可以登录本战网

t
参数: <玩家> <键> <值>
作用:
总管理员可用，设置玩家的个人信息(如最后登录时间BNET\acct\lastlogin_time)等

/motd
参数: l/list
作用: 显示服务器欢迎信息


##############################################################################
# bnetd.conf - Configuration file for the Unix Battle.net daemon #
#----------------------------------------------------------------------------#
# #
# This file is an example configuration and may require modification to #
# suit your needs or your site. Blank lines and lines starting with a "#" #
# are ignored. Use quotes around values that contain spaces. #
# #
##############################################################################

##############################################################################
# File section #
# The pidfile can be set to "" to turn it off. #
# Use absolute paths in these lines to avoid problems! #
#----------------------------------------------------------------------------#
#这里尽量使用绝对路径
 filedir = /usr/local/var/files/
userdir = /usr/local/var/users/
defacct = /usr/local/etc/bnetd_default_user
motdfile = /usr/local/etc/bnmotd.txt
channelfile = /usr/local/etc/channel.list
adfile = /usr/local/etc/ad.list
logfile = /usr/local/var/bnetd.log #建议将这个日志文件更改位置例如logfile = /tep/d2log/bnetd.log
realmfile = /usr/local/etc/realm.list

# #
##############################################################################

##############################################################################
# Message logs #
#----------------------------------------------------------------------------#

# Multiple log levels can be defined by connecting them with a comma (,)
# Available loglevels are:
# none
# trace
# debug
# info
# warn
# error
# fatal
loglevels = fatal,error,warn,info,debug,trace
#loglevels = fatal,error,warn,info
#记录日志文件的等级 ，如果机器配置低可以考虑禁用日志，在loglevels前加“#”号
# #
##############################################################################

##############################################################################
# D2CS settings #

# Version of D2CS server (set to zero to disable version check)
d2cs_version = 0
#此处建议设置为0，能避免兼容性的问题
# Allow D2CS server to change realm name?
allow_d2cs_change_settings = true
#这里一般在设置多国度时使用，true将使用d2cs中指定的国度名称，不使用realm.list
# #
##############################################################################

##############################################################################
# Downloadable files #
#----------------------------------------------------------------------------#

# These filenames are reported directly to the client and are relative to
# the "filedir" directory specified above.

# Auto-updates work now, but remember it will force people to use the
# version specified in the autoupdate configuration file (or newer). Also,
# if it is enabled but the mpqauthfile is not avaliable, clients will hang
# when they first connect waiting for it to download.
mpqauthfile = "IX86ver1.mpq"

#Version check stuff
versioncheck_file = /usr/local/etc/versioncheck
update_bad_checksum = true
allow_unknown_version = true
# # 游戏版本校验，建议如上设置
 ##############################################################################

##############################################################################
# Time values #
#----------------------------------------------------------------------------#

# Time in seconds between account file updates, 0 means wait forever.
usersync = 300
# Number of seconds of inactivity before file is unloaded from memory.
# (only checked during account file updates)
userflush = 1200
#这是users里面的帐号文件保存间隔时间设置
 # Amount of time to delay shutting down server in seconds.
shutdown_delay = 300
# Amount of time delay period is decremented by either a SIGTERM or SIGINT
# (control-c) signal in seconds.
shutdown_decr = 60
#shutdown时的一些等待时间设置
 # #
##############################################################################

##############################################################################
# Policy options #
#----------------------------------------------------------------------------#

# If you don't want people to be able to create new accounts, set this to
# false.
new_accounts = true
#是否开放帐号注册
 # If someone attempts to log in more than once, should it kick off the old
# login, or deny the new one?
kick_old_login = true
#kick_old_login = false

# If a user is creating a new channel, should it be added automatically, or
# prompt them first?
ask_new_channel = true

# Should games with passwords be hidden on the game list?
hide_pass_games = true

# Should games already started be hidden on the game list? (for heavily
# loaded servers)
hide_started_games = false

# Should non-permanent channels hidden on the channel list?
hide_temp_channels = true
#是否隐藏临时频道（未在channel.list中定义过的临时频道）
 # Do you want to use the channel quota feature?
quota = yes
#使用频道发言的限制
 # The following options deal with flood prevention.
#
# How many lines do you accept in quota_time seconds?
# (The default should allow 5 lines in 5 seconds,
# longer time periods allow "bursts" of traffic before the quota is full.)
# must be between 1 and 100 lines
quota_lines = 5

# must be between 1 and 60 seconds
quota_time = 5

# "virtual wrapping", so long lines count as multiple lines
# must be between 1 to 256 chars
quota_wrapline = 40

# absolute maximum characters allowed in a line
# must be between 1 to 256 chars
quota_maxline = 200
#
# How many lines do you accept in quota_time seconds before user is
# disconnected?
# (According to Jung-woo, Dobae is a Korean term for flooding the game server...
# it originally meant "to paint the wallpaper on a new or refurbished house").
# If it less than or equal to quota_lines, there is no warning before
# disconnection so don't set this too low.
# must be between 1 and 100 lines
quota_dobae = 10

# Allow banner for clients?
allow_adbanner = true

# Allow preload all accounts during startup?
preload_account = false
#启动时预加载帐户文件，如果账号不多时可以选择加载
 # Maximum number of kick time for account to ban
account_max_kicktime = 0
#用户最大被kick次数，好像是超过这个限制就被kick到the void去了，没试过
 # Default lock time in hours
account_lock_time = 72
#默认锁定时间，好像是/lockacct是不指定时间，就按照这里的设置，没试过
 # #
##############################################################################

##############################################################################
# Anti-hack settings #
#----------------------------------------------------------------------------#
# The server will keep an ip address list in memory while running. #
# Each ip address will have an hack level set which is initial to zero #
# When server think a user is cheating or hacking. the hack level for the #
# ip address which the user connect from will be increased by a certain #
# number (which depended on the hacks user have done) #
# When the ip address hack level exceed the maximum level allowed, #
# The ip address will be banned for a certain period of time #
# To prevent user banned from mistake, the hack level for each ip address #
# will be decreased by 1 after a certain interval. #

# Maximum hack levels allowed before the user to be banned
max_hack_level = 10

# How many seconds will the ip address to be banned if hack level exceed #
hack_ban_time = 3600

# How many seconds will the hack level be updated (decreased) #
hack_update_interval = 60
#这里是新加的防止hack功能，比如屡次输入错误的密码，就会被自动banip
 # #
##############################################################################

##############################################################################
# Server network info #
#----------------------------------------------------------------------------#

# Set this option to true to allow TCP to detect and close stale
# connections.
#use_keepalive = false

# This is a comma delimited list of hostnames that the server should
# listen on. It might be useful to make an internal-only server on a
# gateway machine for example. If the list is not set or if it has a
# entry with no host component, the server will bind to that port on all
# interfaces.
#servaddrs = ":9999"
#servaddrs = "myinternalname.some.com,localhost"
#servaddrs = ":" # default interface (all) and default port (6112)

# Don't change these unless you really need to! You will need to run a proxy
# or modify the clients. Also note that these will not change when simply
# sending a HUP signal to the server; they are only read on startup.

# #
##############################################################################


#################################################################################
# d2cs.conf - Configuration file for the diablo2 game control server #
#-------------------------------------------------------------------------------#
# #
# This file is an example configuration and may require modification to #
# suit your needs or your site. Blank lines and lines starting with a "#" #
# are ignored. Use quotes around values that contain spaces. #
# #
#################################################################################

#################################################################################
# Server Major Settings #
#-------------------------------------------------------------------------------#
# #
# Your realm server name #
realmname = D2CS
#国度名称，如果bnetd.conf中设置allow_d2cs_change_settings = true，这里就生效了
 # This is a comma delimited list of hostnames that the server should
# listen on. It might be useful to make an internal-only server on a
# gateway machine for example. If the list is not set or if it has a
# entry with no host component, the server will bind to that port on all
# interfaces.
# d2cs default listening port is 6113
servaddrs = 0.0.0.0:6113
#指定d2cs监听的端口，不需修改
 # Realm server address, this is the address used by bnetd to report to client
# Make sure client have direct connection to this address
# Set to blank to leave bnetd's settings unchanged
#realmaddr = "192.169.0.1:6113"

# This is a comma delimited list of game servers
#gameservlist = your.gameserver,another.gameserver
#d2gs的列表，做多game server用的，注意把前面的#去掉
 # This is bnetd server address with port
# bnetd default listening port is 6112
bnetdaddr = "127.0.0.1:6112"
#bnetd的地址和端口
 # #
#################################################################################

#################################################################################
# Message logs #
#-------------------------------------------------------------------------------#
# Multiple log levels can be defined by connecting them with a comma (,)
# Available loglevels are:
# none
# trace
# debug
# info
# warn
# error
# fatal
#loglevels = fatal,error,warn,info
loglevels = fatal,error,warn,info,debug,trace
#记录日志文件的等级 ，如果机器配置低可以考虑禁用日志，在loglevels前加“#”号
# #
#################################################################################

#################################################################################
# File and Path section #
# Use absolute paths in these lines to avoid problems! #
#-------------------------------------------------------------------------------#
# #
#最好使用绝对路径
logfile = /usr/local/var/d2cs.log #建议将这个日志文件更改位置例如logfile = /tep/d2log/d2cs.log
charsavedir = /usr/local/var/charsave
charinfodir = /usr/local/var/charinfo
ladderdir = /usr/local/var/ladders
newbiefile = /usr/local/var/files/newbie.save
# #
#################################################################################

#################################################################################
# Misc #
#-------------------------------------------------------------------------------#
# #
# Message Of The Day, support hexcode
motd = "Tips: How to use color in your profile(Right click on your portrait to open pr ofile editing). Use \\\\xffc as Prefix (\\\\xff means ascii code 0xff,but you should use copy/paste trick to in put it, c means character 'c'. Color also works in game chat,but have input limit). Then append the Color chara cter list below: \\xffc0White '0' \\xffc1Red '1' \\xffc2Green '2' \\xffc3Blue '3' \\xffc4Gold '4' \\xffc5Gray '5' Black '6' \\xffc7DarkYellow '7' \\xffc8Orange '8' \\xffc9Yellow '9' \\xffc:DarkGreen ':' \\xffc;Purple ';' \\xffc<LightDarkGreen '<'"
#就是“大厅”中右边的那些DD
 # Set to non-zero to allow creation of new realm character
allow_newchar = 1
#是否开放注册新角色
 # Do you want d2cs to check client for multilogin for security reason?
check_multilogin = 0

# Maxinum number of character per account
maxchar = 8
#一个帐户可拥有的角色数，超过8个就需要用键盘的方向键了，因为没滚动条
 # Maxinum number of games will be shown in join game list
# Zero = infinite
maxgamelist = 20
#game list最多显示的游戏数目，0无限制，20是个很好的选择
 # Set to non-zero to allow show all games with difficulty < character difficulty
# Otherwise, only game with difficulty = character difficulty will be shown
gamelist_showall = 0
#0只显示玩家相同级别的游戏normal的只能看见normal的，1显示<玩家等级的游戏hell的可看见nightmare和normal的
 # Maxinum time in seconds that a user can idle
# Zero = infinite
idletime = 3600

# Amount of time to delay shutting down server in seconds.
shutdown_delay = 300

# Amount of time delay period is decremented by either a SIGTERM or SIGINT
# (control-c) signal in seconds.
shutdown_decr = 60
#shutdown的延迟时间设置
 #################################################################################

#################################################################################
# Internal System Settings #
# You may just ignore them and use the default value #
#-------------------------------------------------------------------------------#
#
# How often will the server purge all list to clean unused data (in seconds)
listpurgeinterval = 300

# How often will the server check game queues (in seconds)
gqcheckinterval = 60

# How often will the server retry to connect to bnetd
# when connection lost (in seconds)
s2s_retryinterval = 10

# How long time the s2s connection will timeout
s2s_timeout = 10

# How often the server will check server queues for expired data
sq_checkinterval = 300

# How long time will a server queue data expire
sq_timeout = 300

#上面这些server to server的设置不晓得是干什么的，估计是d2gs和d2cs服务器间的通信
 # Game serer binary files checksum, use zero to skip this checking
d2gs_checksum = 0
#d2gs连接的时候检验checksum
 # Game server version, use zero to skip this checking
d2gs_version = 0
#d2gs连接的时候检验版本
 # Game server password
d2gs_password = ""
#d2gs连接的时候检验密码
 # Maxinum number of second that a game will be shown on list( zero = infinite )
game_maxlifetime = 0
#游戏最大时间，这些设置可以参见精华区的另一个帖子
 # A game will be automatically destroied after how long time idle
max_game_idletime = 0

# Allow Limitation created game with password, player number or level limit?
allow_gamelimit = 1
#是否开启游戏密码和人数的限制
 # Ladder refresh time
ladder_refresh_interval = 3600

# server to server connection max idle time in seconds
s2s_idletime = 300

# server to server connection keepalive interval
s2s_keepalive_interval = 60

# all connection timeout check interval
timeout_checkinterval = 60

# game server restart interval
d2gs_restart_delay = 300

#
#################################################################################


游戏排第一位的问题
这是个最让人头痛的问题，但大部分还是能解决的！出现排位1的问题要从以下几个方面入手
1;没有gs或者gs没有启动
2;gs配置不对，修改注册表文件d2gs.ren中的ip为你的d2cs的ip地址
3;d2dbs.conf和d2cs.conf中没有添加gameservlist
4;gs版本和d2cs不配套
5;gs console中设定的maxuser和maxgame有误
6;使用了安装版的暗黑游戏（包括正版），我遇到过这样的问题。
7;导入的GS端的注册表文件{d2gs.reg}中
"D2CSSecrect"="NENU" 这个选项非空或者和国度名不符
例子：zixia的1.09beta的d2gs下载使用后出现排位1的问题，就是这个原因引起

解决排位1的步骤：

1:telnet gsip 8888[注意空格] 密码是abcd123 gsip 是你安装了d2gs和暗黑游戏的机器的ip地址
能登陆往下看，不能登陆没有安装d2gs服务或者d2gs服务没有启动，此种问题见[2]和[5]
2:登陆后，使用命令status得到游戏服务器的状态，以下是Nenu战网实例
Maximum game number: 149//最大游戏数，此项为零即无法建立游戏，
Current game number: 132//当前游戏数
Current users in game: 221//当前玩家数
Maximum prefer users: 0
Maximum game life: 7200 seconds//游戏的生存时间
Connetion to D2CS(202.198.141.7): connected//d2cs链接中
Connetion to D2DBS(202.198.141.7): connected//d2dbs链接中
GS log to file: Disable//禁止gs日志
Physical memory usage: 260.898MB/284.832MB//已用gs物理内存
Virtual memory usage: 377.781MB/398.934MB//已用gs换页空间

会出现排位1的有这几项
1：Maximum game number: 149//最大游戏数，此项为零即无法建立游戏
这个简单，见[4]
2：Connetion to D2DBS(202.198.141.7): fail//d2dbs链接失败
这个是因为关于d2dbs设置错误，请检查你的设置文件和你是否启动了d2dbs服务
3：status输出是正常的，可是我还有排位1的问题
一般来说这就是bnetd和d2gs版本的配合问题了，但是我遇到过这样的输出的2个特例
<1>我用了zixia的d2gs
<2>我用了正版安装的暗黑游戏
4:bnetd和d2gs的版本配合（不能混用）
bnetd 0.4之前和bnetw 对应d2gs版本1.06，无法防止dupe
bnetd 0.5 对应d2gs版本1.07，可以防止dupe，主要是因为zixia的老大还在维护这个d2gs版本
5：最后的建议，安装完d2gs后，一定要去系统中的服务面板中，把d2gs服务从新启动一次


无标题文档

 从本站网友阿吉的论坛转来
大家问问题之前，先看看精华区有没有相关帖子。
我会把常见问题列在这个置顶贴里，看完确认没有你的问题，再问。
本贴将持续更新（如果想起什么的话）大家也可以帮忙补充，写成下面的格式。

除非特别情况，不要在qq或者私人信息里提问。一方面，公开提问会有更多的人回答，一方面，你的问题可能可以给其他人有帮助。

Q:我想建个d2 server,谁能帮帮我？

A:大家都会帮你，不过你要先看看各bbs的架设d2 server相关帖子。如果你连d2 server用哪些软件构建都不知道就提问，很少有人有耐心重头给你讲，包括我。当你提问时，我们假设你已经看过很多安装向导并知道d2 server架设的基本条件,但过程中遇上麻烦了。

如果你一点头绪都没有，我们建议你访问

这个http://www.d2cn.com/down/index.asp?classid=16

还有http://opac.nenu.edu.cn/cgi-bin/forums.cgi?forum=16

后一个是奶牛论坛的GM专区，我开始的时候从那里学到很多。

这个链接，下载相关安装向导和说明

我们建议你阅读这个板块的f&Q和精华，以便你获得更多有用的信息。

同时，本版提供最新的bn软件支持

Q:提问时我写什么样的标题比较容易得到帮助？

A:提问也是有技巧的，你的标题最好写明问题，最好让人一看就知道你大致是什么问题。附标题加上点描述以吸引人。内容责描述清楚状况，比如你做了什么，在什么操作系统，用什么软件，做到哪部分出了问题。
如下标题就是很没有技巧甚至会被别人忽略不读的（当然，帖子少的时候都会读啊^__-）:
"急!"(或三4个感叹号)
"xxx进"
“请教！”
“我可以问个问题么？”

如下内容是很空洞的：
"为什么我的pvpgn(bnetd)不能启动？"
“为什么我的d2 server不能正常运行？”
空洞而广泛的范围会让人看了生畏，仔细描述问题和步骤才有利于快速解决问题。

---------------------------------------------------------------------------------

A:wc3服务器和sc服务器如何架设？如何实现网页ladder？
wc3和sc再pvpgn上都是用开放式互联来模拟ladder的，所以，客户端之间必须能互访才能打ladder游戏。web 排行可以用pvpng-stats＋（mysql+pvpgn)的方式实现，pvpgn-stats使用见精华列表。也可以打开pvpgn的xml 输出ladders数据，然后用你知道的方法解析xml. pvpgn再sf.net的项目列表有专门的php web程序下载，包括mysql操作或者xml操作的。你可以去看看。

Q:bnetd/pvpgn, d2cs,d2dbs, d2gs启动关闭的正确顺序是什么？

A:尽管这些服务程序之间都有重试链接的功能使得你在任何顺序都可以获得正常的服务，但建议你用如下顺序避免一些问题出现。

启动: pvpgn(/bnetd)->d2cs->d2dbs->d2gs....
关闭:d2gs...->d2cs/d2dbs->pvpgn/bnetd

特别注意关闭顺序，不正常的关闭顺序，如果玩家准确掌握你关闭服务的时间，可以人为利用不正确的关闭来达到单独回档的目的。所以，建议使用shutdown命令关闭d2gs以强迫gs上所有游戏被动存盘。再关闭其他服务，而不是闪电式的在关闭d2gs前关闭d2dbs,d2cs。

Q:pvpgn如何支持外网客户端对内网服务器的游戏访问？

A:pvpgn通过realm.list的配置告诉外网客户端d2cs所在(映射断口的服务器），d2cs通过d2gstrans的配置发送不同的地址（内网，外网）给内，外网不同用户。当然，你必须在网关做d2cs 端口6113，d2gs 4000端口，bn 6112端口倒内网服务器的映射。

Q:我什么都正确配置了，d2文件也全了，版本也正确，但是d2gs服务无法正常运行。查看windows任务管理器发现很多d2gs.exe的进程无法杀掉!!!

A:d2gs110 beta-6用到了msvcp60.dll这个VC 运行时库，如果没有更新的替代版本，请从网络下载或者其他机器copy来放到你的widows目录下的system32目录，重启机器消除d2gs.exe后再运行d2服务。

Q:pvpgn如何建立一个NAT内网上网的客户端可以打ladder的魔兽战网?

A:pvpgn模拟的war3战网,war3的所有游戏(包括ladders)都是从客户端中选出一个做主机的.
所以,只有客户端间互相可达的情况下才能正常玩ladders.很遗憾的,wc3游戏对战是点对点的链接,目前(2004-05-09)没有支持NAT的可能.(也许哪天某高手开发出支持的loader也不定).当然,如果只有1个内网,则可以配置gametrans和映射端口来解决这个问题,具体请自行摸索.其他开放式互联的客户端也类似(sc,diablo, diabloII open).

关于gametrans的用处及其配置:
http://www.lostcity.cn/bbs/index.php?showtopic=2045

Q:pvpgn1.62+d2gs110 beta6建立战网后排队!

A:很多人遇到这个问题.据说可能是pvpgn的d2server.ini文件格式有误会导致排队,d2gs所带的d2server.ini替换pvpgn 的conf目录里的d2server.ini试试.我本人没有遇到这个问题.因为我自己edit过d2gserver.ini才启用战网.
在本版提供的pvpgn1.62ap2下载中已经替换了这个文件.pvpgn原版则保留pvpgn发布的文件.
d2gsserver.ini

Q::如何在中文版本客户端显示中文news？
http://www.lostcity.cn/bbs/show.php/act/ST/f/12/t/1159
其实就是将utf-8的中文字符存成ascii模式。不过，提醒pvpgn用户注意，使用这样的改动后要关闭/news命令,否则，客户端使用news就down pvpgn了。... ?

Q:为什么我架设好pvpgn战网服务器，但客户端进入时老是提示版本出错？
A:版本检测问题。请参看本版精华中关于versioncheck的设置。

Q:如何提高战网掉宝率（经验，快速升级）？

A:我本人不提倡这样做，虽然520这样的站点似乎很成功，但修改绝对不是留住玩家的方法,亦没有相关经验。实际上，只要将单机可用的修改好的patch_d2.mpq文件覆盖替换服务器上的即可。相关类似修改mods的问题到【游戏小站】（本站有友情连接）可能过更容易得到答案。

Q:我配置好了所有该配置的地方，还是无法让战网正常运行！
A:配置文件时一个比较常放的错误是配置项"="号两边没有留出空格。
比如
gameserverlist=127.0.0.1 (错)
应该是
gameserverlist = 127.0.0.1 (对)
在linux下使用bnetd时，有梅举类的配置项甚至在最后面不能有空格或者tab。呵呵
比如 "gameserverlist = 127.0.0.1,127.0.0.2"(正，不要包括"号哦，仅仅用来说明字符结束位置)

"gameserverlist = 127.0.0.1,127.0.0.2 "(错，最后有空格了。 ?)

Q:怎么修改110战网 ladders存档？
A:最新的atma5.02可以更改ladders存档---0525
A:目前没有专门的110修改器。但109的存档在110被当作普通模式存档，而普通模式存档可以用faster老大的程序（本站提供了binary下载）转换为ladders人物，或者，你 可以用内存修改工具修改d2gs启动的游戏。

http://www.lostcity.cn/bbs/index.php?showtopic=458

Q:我按照说明修改了acc里面的关于admin项目，怎么还是没有起效？
A：修改时你必须down下bn,否则pvpgn或者bnetd会定期从内存同步acc资料到存档。

Q:如何从bnetd-thread转到pvpgn1.60 beta1?
A:自己测试一下先。会发现a
pvpgn和bnetd-thread只有存储管理方面稍微有点不同。
bnetd采用了目录索引的方式来存放users, charinfo, charsave。
pvpgn则把这些档放到一个大目录下.注意，pvpgn中acc存档使用了useid项，不能再等0了。另外，"bnet\\auth\\lock"="true"项目在pvpgn变成了，"bnet\\auth\\lockk"="true"！如果你不注意，转换后就释放了你所有的以前锁住的acc了

charinfo和charsave的文件简单用copy功能即可处理。
把users文件方式转换到mysql数据库存储，请找script目录上对应的脚本转换即可。

Q:1.10天梯怎么设置？

A:在d2cs.conf有
# ladder start time
# format: yyyy-mm-dd hh:mm:ss
ladder_start_time = ""
项目即为天梯开始时间设置。赛季没有周期，知道你设置下一个起时时刻。
在时刻前建立的人物，无论客户端是否选择了天梯模式，都在普通模式出现。
反之亦然。

Q:pvpgn160beta1 src for *nix没有configure,怎么安装？？A:用同一目录得autogen.sh文件生成configure文件先。

Q:pvpgn或bnetd如何添加第一个admin?
A:请仔细阅读conf\command_groups.txt文件，pvpgn采用了灵活的组权限分配方式可以分布任意命令到任何组。

文件方式存储的acc给admin增加
"BNET\\auth\\command_groups"="255"
"BNET\\auth\\admin"="true" 二项 (bnetd单独添加此项即可)
mysql请置admin acc对应的auth_admin字段为true
auth_command_groups 为255
参阅/cg命令和command_groups.txt的内容可以建立一套自己的命令权限机制。

Q:如何从使用d2closed的存档升级到pvpgn 160 beat1的d2dbs,d2cs组合？
A:我发现只有charsave下的存档文件名需要稍微做一下转换，即去掉d2s后缀。

Q:我按指南作了全新的服务器，但建立新人时老提示人物已经存在！
A:可能你在d2cs.conf 设置了 不许建立新char
还可能你的charinfo, charsave目录不存在(pvpgn 160 beta1没有却省建立这2个目录)

Q:谁可以告诉我从哪里可以得到支持d2x 110的GS?
A:本站有下载。找找

Q:bnetd-thread5.3.1支持110的d2 closed server架设么？

A:不支持。请用新版本的pvpgn或者紫侠提供的bnetd

2.www.pvpgn.cn
3.www.pvpgn.de

Q:怎么修改站网存档？

A:把 charsave下对应存档copy出来，加上类似本地存档的后缀，用修改器修改，在本地可以正常使用后，去掉后缀copy回站网对应位置即可。

Q:Bnetd-thread可以架设sc服务么？

A:Bnetd-thread不支持WARIII,SC, PVPGN支持！

Q:为什么建立游戏还是会排队？

A:1.d2gs没有正常启动(查看d2gs日志)，或者没有能和d2cs,d2dbs正常连接，你必须能telnet 到d2gs的8888端口(初始密码是abcd123,记得改哦)，用status命令查看和d2cs,d2dbs的连接情况。
2.你的d2gs注册表配置项的"D2CSSecrect"键值非空，但又没有在d2cs.conf配置(1条提到的d2cs connect应该不正常)
3.d2cs.conf配置了checksum,但和d2gs version命令中的checksum不对应(1条提到的d2cs connect应该不正常)。
4.realm.list和d2cs国度名没有对应
4.5 d2GS的max games数目或者max users数目没有设置对。
5。再仔细看一遍d2 server架设向导。
所有排队现象都只有一个原因，gs无法响应cs建立游戏的请求或者gs不能相应客户端加入请求。或者d2cs发送了错误的gs位置给客户端。

其中包括，gs人数或者game数字满，gs没有正常连接cs,或者gs没有正常连接dbs 三种情况。自己弄懂各部分工作原理，仔细检查，看日志，并思考就可以解决问题

Q:新版本bnetd-thread或者pvpgn可以防止dupe和rb么？

A:dupe和rb一般是通过d2gs工作的，和bnetd关系不大。

Q:bnetd-thread或pvpgn可以防止bot和外挂么？

A:不可以，你只能从日志分析自己抓到使用hack的人,或者雇几个苦力（online GM）给你在线看着那些家伙()。

Q:我在windows下运行bnetd-thread或者pvpgn，日志充满窗口和增大了日志文件，怎么处理？

A:soarchin的bnetd-thread中的三个程序bnetd,d2cs,d2dbs都可以用--install安装为windows service（服务程序）方式运行，配置对用的conf文件的loglevels 可以减少不必要的日志输出。

pvpgn则可以用pvpgn(s) -s install(/uninstall)来安装或者删除对应的service。

Q:bnet-thread或者pvpgn建立d2 server后连接提示“没有国度”或“国度饲服器停机”是怎么回事？

A:确保你已经正确的连接了d2gs,d2cs,d2dbs,bnetd。realm.list文件里面必须设置国度名和对应的国度服务器（d2cs）所在地址和端口号。这里的国度名必须包含所有的d2cs配置的国度名（如果你有多个国度）。

Q:我可以在单机建立多国度么？

A:不可以，每国度至少需要一个独立工作的d2gs。

Q:如何关闭bn的oplog？

Soarchin: 关掉oplog的方法我在conf中有说明，oplogdir设为""即可
注意要同时改bnetd.conf和d2cs.conf

Q:你能帮我改改我的配置文件么？我按说明做了，还是没搞好服务器。

A:我们不是保姆，我们可以给你尽多的提示性或参考性的帮助，但我们不希望甚至配置文件也要替你修改好。自己翻看老贴，精华，置顶。你遇到的问题，也许大家早先也遇到过。如果你了解了bn运作的原理，所有的问题都只是使用的问题。